Skip to main content
← All vulnerabilities
CVE-2026-11440

theonedev REST API default-branch improper authorization

Published
Last modified
published
Not listed in CISA KEV
Fix
Fix or patch referenced
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • theonedev onedev

    15.0.0, 15.0.1, 15.0.2, 15.0.3, 15.0.4, 15.0.5

References 6

VulDB

cnblogs.com

GitHub · theonedev/onedev