Skip to main content
← All vulnerabilities
CVE-2026-111908GHSA-J3PX-R7CR-R26R

phpMyFAQ 4.0.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta BOLA in FAQ Update via REST API

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.9, 4.2.0-beta
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

phpMyFAQ 4.0.0 before 4.1.9 and 4.2.0-alpha before 4.2.0-beta contains a broken object-level authorization vulnerability in the PUT /api/v3.1/faq/update endpoint, which checks only the global edit_faq permission and does not verify access to the target FAQ. Authenticated users with edit_faq permission can supply the ID of a restricted FAQ they cannot view to modify its content, bypass moderation, and change its publication state.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • thorsten phpMyFAQ

    From 4.0.0 · fixed in 4.1.9

  • thorsten phpMyFAQ

    From 4.2.0-alpha · fixed in 4.2.0-beta

References 2

GitHub · thorsten/phpMyFAQ

vulncheck.com