Skip to main content
← Vulnerabilities

Apache Syncope: AuthProfile value escalation via self-service update

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

—Not rated
Exploited
No known exploitation
Fix
No fix listed
Who is exposed
Not reported
Published
Last modified
Published
Not listed in CISA KEV
5/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Syncope, an open-source identity management system, is affected. A flaw lets regular non-administrator users change their own authentication profile to enable impersonation, allowing them to act as other users during login and gain access beyond their intended privileges.

Read the original description

Improper Privilege Management vulnerability in Apache Syncope. AuthProfile self-updates allow non-admin users to configure impersonation for WA surrogate authentication. This issue affects Apache Syncope: from 3.0.12 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated

Affected versions

  • org.apache.syncope.core.am:syncope-core-am-logic

    From 3.0.12 · through 3.0.16; From 4.0.0-M0 · through 4.0.8; From 4.1.0-M0 · through 4.1.3

Evidence 1

  1. Advisory

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.